Support Center

How can I export Route Plans to GPS devices?

Last Updated: Feb 13, 2015 01:25PM EST
From the Viamente Route Planner you can send to your Drivers .itn files (for TomTom devices), .gpx files (for Garmin and other devices) and .freshroute (for Navigon devices).

In order to do this, you need to define the type of GPS device for each of your Drivers.

From the tab My Fleet (top left) click on Create Driver to create a new Driver or on the blue link Driver's Details for editing an existing Driver's details (read more about it here).

A setting window will pop up and in the field Email content you will be able to select the type of GPS device and consequently the type of file that your Drivers will receive.




When all your Routes have been optimized and your Route Plan is ready, from the tab Route Plans, right under Add Orders, three buttons give you different options for exporting and sharing your optimized Routes.



The first button allows you to print your Routes, but for obtaining files for GPS devices we need to press the second or the third button:
  • Export Routes (Excel/CSV, files for GPS devices, Route Links).
  • Send Routes via email (Route Links and files for GPS devices)
Please note that by clicking Export Routes --> Export as GPS files you can download the files directly from here, choosing different formats (regardless of the format you specify for your Drivers' email).

After downloading or sending the files, you or your Drivers will only have to upload them to your device.

You may want to make sure that your GPS navigator supports file uploading and multi-stop routes.

NOTE:
The procedure for the upload to different devices may be different from the one indicated below. Always double-check with your manufacturer that the GPS device you have or you want to buy meets your exact requirements and supports file uploading and multi-stop routes.

Please refer to GPS manufacturer's Customer Service for detailed upload instructions of the files.



 

Tom Tom Devices

 

General information on TomTom devices

Remember to check in your User Guide or with your manufacturer if your device supports file uploading and multi-stop routes. When you read a device's specs, TomTom calls this function Itinerary Planning. If this voice is not mentioned in the User Manual, the device does not probably support it.

For your information, we have noticed that most TomTom devices support a maximum of 48 waypoints, but when routes with more waypoints are exported from Viamente, they are automatically broken down into smaller routes, each of which starts where the previous one finishes.

This same behavior occurs with Garmin devices - but they limit it to 29 stops.



General Instructions for uploading Viamente files to TomTom devices

 
As far as TomTom devices are concerned, your Drivers can install a free software, called TomTom Home, to upload .itn files to their device.
 
Alternatively, they can also access directly the TomTom device folder "/itn" and paste the file there. Here are the instructions (please note that this procedure was tested on one device and that steps may differ from one device to the other):
 
1. Connect your TomTom to your PC via USB lead provided
2. Press yes on TomTom to accept computer connection
3. Go to My Computer
4. Right Click on the TomTom icon
5. Click Explore
6. Double click on /itn folder to open it (if no itn folder exists, select Itinerary planning from the main menu of your TomTom and a folder named itn will be created).
7. Copy the .itn file downloaded from the Viamente Route Planner into the /itn folder on your TomTom device
Note that TomTom devices accept .itn files with up to max 48 stops.

 

Garmin devices

 

General information on Garmin devices

Remember to check in your User Guide or with your manufacturer if your device supports file uploading and multi-stop routes. When you read a device's specs, Garmin calls this function Routes (a corresponding value of zero means the device does not support it).

For your information, some Users have reported that even though you can upload Routes on some Garmin devices, spoken navigation instructions are not available for the imported routes.
 

Instructions for uploading Viamente files to Garmin devices

You can follow these instructions (please note that this procedure was tested on one device and that steps may differ from one device to the other):
 
1. Connect the device to your computer: your nuvi and memory card appear as removable drives in My Computer in Windows and as mounted volumes on Mac computers.
2. Browse your computer for the .gpx file you have received from the Viamente Route Planner and copy it.
3. Open the "Garmin" or memory card drive/volume and paste the .gpx file.
4. Once you have safely unplugged the device from your computer, you can navigate the Garmin menu in this way: Tools > My Data > Import Routes > so you can import the Route you have just copied.
At this point, you are ready to start your Route: navigate the menu of your Garmin this way:  Tools > Routes, select the Route and get ready to go!

On the web, you can also find several other third-party services (like this) which you may want to try to get different file formats for other devices, but we have not tested them all and we do not know if they work fine.

Contact Us

http://assets0.desk.com/
false
ViamenteRouting
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete